JOT - Judicial Offense Tracker Documentation


Overview

The Judicial Offense Tracker is an easy-to-use database system for tracking all of the information related to judicial cases -- the people involved, the details surrounding the case, the offenses charged, the results of any hearings or appeals and the sanctions imposed as a result. School administrators and Judicial Affairs Offices will save time and operate more efficiently than possible with manual record keeping or home-grown databases. You may easily check for past offenses by any particular person and quickly view a complete summary. A large number of reports are available with many different options to quickly provide the end of your statistics and summaries that you need. Easily monitor the status of sanctions and simply run a report to see any uncompleted sanctions or unpaid fines.


Tutorial

A good way to start learning JOT is to go through our Tutorial. This will guide you step-by-step through the process of using the program and entering information in the database


Initial Setup

Before starting to use the program actively, it is good to give some thought to the initial setup of some of the options available in the program. All of the fields that appear as drop-down lists in the program (category and process method, for example) may be fully customized by the user. When the program is first installed, a list of options is available for each of these fields, but this is only our suggestion for the purposes of providing some sample data. You may modify the options we provide, or delete them all and enter your own. In this way, you may specify all of your own charges, sanctions, groups, categories and process methods.

Similarly, the people available to associate with cases may be easily modified at will. You may either enter people individually using the Maintain People menu option, or you may use the Import People option on the File Menu to automatically add a large number of people using a data file from a different database system.


How to Contact CyberNiche Software

You may contact CyberNiche Software by mail, by e-mail, by fax or by phone.

CyberNiche Software
35 Winchester Gardens
Carlisle, PA 17013
USA

e-mail: support@cniche.com

Phone: 717-486-8308
Fax: 267-295-6127

Our web site is at: http://www.cniche.com/


Custom Programming

While we make every effort to make our software flexible and powerful enough to meet the needs of most of our customers, we recognize that certain users will have unique requirements that are not always satisfied by the software. In response to such special requirements, we are able to customize the software according to your exact specifications. We can add additional fields, change the labels of screen fields, develop new reports or anything else you may require. Contact us at CyberNiche Software for a quote on custom changes to Judicial Offense Tracker.


Cases

The main window of the program presents an overview of all of the information associated with an individual case. Cases are sorted alphabetically by the name of the person involved. You may use the navigation buttons at the bottom of the window to move between the different cases. First will move to the first case in the database which is displayed by default when the program first opens. The Previous and Next buttons will move case-by-case through the database. The Last button will move immediately to the very last record in the database.

Once any number of cases have been entered, it will be much easier to locate an individual case by using the Find button. Clicking on Find will display the search window where you may select the field that you wish to search and the specific information that you wish to search for.


Adding new cases

Click on the Add New button to add a new case to the database. Enter information for all the fields you wish to track in the program by tabbing through the screen fields. When you have finished entering the case's information, click on the Update button. If you change your mind about entering the case, click on the Cancel button. After you have saved the record, click on the Charges and Sanctions buttons to add any charges or sanctions associated with the current case.

If you're entering a number of cases at once, you may click on the Add Another button instead of clicking Update. Clicking on Add Another will save the information you have just entered as a case record and clear the window so that you may immediately began entering the next case. (Note that you will need to go back to enter charges and sanctions, as charges and sanctions cannot be added to a new case record until it has been saved.)


Finding a Case

Click on the Find button to locate the information for a particular case. After you click this button, a window will appear where you may select the field, the operator and the text or value to find. Text fields may be searched for specific text in various positions. For number, currency or date fields, you may select operators such as equals, less than, greater than, etc. True/False fields allow you to select either true or false.

If more than one record is found that matches your search, all matching records will be displayed in a list:

The case number, incident date and name will be displayed for each matching record. Select the case you wish to view and click the Select button.


Case Data Fields

The information for each case is recorded in the fields listed below. Our explanation for the purpose of a field should be viewed as a suggestion only. Generally, you may enter other information of the same type in any of these fields. A date field will only accept a date value, however. Through custom programming, CyberNiche Software can alter the program to change field labels, change the type of information stored in fields or add any additional fields that you might need.

Name -- the name of the person associated with the case. Select the name from the drop-down list. In a long list, you may press the first letter of the person's last name to immediately skipp down to the names starting with that letter. The available names are those that have been entered through the Maintain People menu option or have been imported with the Import People command.

Case ID -- is a sequential number that is automatically assigned by the program to each case. This is an internal ID that cannot be modified by the user. It is displayed only after a new case record is saved with the Update button.

Case Number -- this is an alternate case identifier that the user has full control over. If you are following your own established case numbering scheme, you may enter your own case number here. You may also enter a duplicate number here so that cases associated with multiple people may share a case number. If you do not enter a case number in this field, the program will automatically assign a seven character case number based on the case ID.

Entry Date -- the date that the case information was entered in the database. When you create a new case record, the current system date is automatically entered into the entry date field, but you may change this to any other date if you wish. Click on the calendar icon following the date to display a small pop-up calendar from which you may select an alternate date. Entry date is a mandatory field -- you must enter a valid date before you are able to save the case record.

Incident Date -- the date that the incident to case relates to occurred. This also defaults to the current date and can be changed in the same way as the entry date. The incident date is the main date associated with the case. When you generate reports that are limited to certain cases by date, it is generally the incident date that the program uses to determine whether or not a case should be included in your report.

Incident Time -- the time that the incident occurred. This is a text field that will accept times or time ranges in any format, e.g., "1 to 2 am" or "about 8pm."

Hearing Date -- the date on which the hearing occurred.

Heard By -- the person or group who heard the case. This is a text field which may hold up to 40 characters of information.

Report Date -- the date on which the incident to case relates to was reported.

Reported By -- the name of the person or group who reported the incident.

Category -- this is a drop-down list from which a predefined category can be selected. Use the Maintain Categories command on the Maintain Menu to modify, add or delete categories. The category is useful for reporting purposes as many reports can be limited to a specific category of cases.

Process method -- select the processing method from the drop-down list. Use the Maintain Process Methods command on the Maintain Menu to modify, add or delete process methods.

Summary -- this is a space for a text description of the details surrounding the case. Text will rack in this multiline text field and you can enter as much information as you wish.

Appeal Date -- the date on which an appeal was heard. The report listing appeals will determine whether or not a case should be listed on the report by the presence of an appeal date.

Appeal Heard By -- the person or group who heard the appeal.

Appeal Findings -- the findings of the appeal. This is a multiline text field that can accept any amount of text.


Witnessses

Witness accounts that have been entered for the current case are displayed in a list in the bottom left of the main screen. To maintain the witness accounts for an individual case, click on the Witnesses button immediately above the list. A new window will appear that will allow you to add or delete witness accounts for the current case.

The controls in the Witnesses Window parallel those in other parts of the program. Click on the Add New button to assign a new witness account to the case. Use the navigation buttons (Previous, Next, Etc.) to view the different witness accounts that have been assigned. Click on the Delete button to remove the currently displayed witness account from the case.

When adding a new witness account, a shortcut is provided for names that have not already been entered in the program through an import or Maintain People. You may either select the name of an existing person's record from the list or you may enter a last and first name in the fields provided. When the new witness account record is created a new person record will also be created. You may access this record later through the Maintain People menu command to add address, phone or other contact information.


Charges

Charges that have been assigned to the current case are displayed in a list in the top right corner of the main screen. The charges are color-coded with charges appearing in green if they have not been marked as "found responsible" and in red for charges that have been marked "found responsible". To maintain the charges for an individual case, click on the Charges button immediately above the list. A new window will appear that will allow you to add or delete charges for the current case. (Note: use the Maintain Charges command from the Maintain Menu to modify the list of all available charges that the program recognizes.)

The controls in the Charges window parallel those in other parts of the program. Click on the Add New button to assign a new charge to the case. Select the charge you wish to add to the case from the list. Use the navigation buttons (Previous, Next, Etc.) to view the different charges that have been assigned. Click on the Delete button to remove the currently displayed charge from the case. Place a checkmark in the "found responsible" field for any charge where the defendant was found responsible.


Sanctions

Sanctions that have been assigned to the current case are displayed in a list immediately below the Charges list on the main screen. The sanctions are color-coded with sanctions appearing in green if they have been marked as completed, in yellow if they have not been completed but are not yet overdue, and in red if they have not been completed and are overdue. To maintain the sanctions for an individual case, click on the Sanctions button immediately above the list. A new window will appear that will allow you to add or delete sanctions for the current case. (Note: use the Maintain Sanctions command from the Maintain Menu to modify the list of all available sanctions that the program recognizes.)

The controls in the Sanctions window parallel those in other parts of the program. Click on the Add New button to assign a new sanctions to the current case. Select the sanction you wish to add to the case from the list. Additional fields allow you to enter any details related to the sanction, a dollar amount if there was a fine involved, a due date and a completion date. Use the navigation buttons (Previous, Next, etc.) to view the different sanctions that have been assigned. Click on the Delete button to remove the currently displayed sanction from the case.


File Menu Commands

Commands located on the File Menu allow you to import people into the system using a data file from a different system or exit from the program.

Importing People

The Import People option on the File Menu accepts a tab delimited text file. The file should have one person record per line with a tab separating each field. The fields in the data file must be in the following order:

Alternate ID
First Name
Last Name
Phone
E-mail
Class
Address Line 1
Address Line 2
Birth Date
Group
Miscellaneous

Note: an import routine that supports a different data format can be provided to you through custom programming. Contact CyberNiche Software for details.

If the other system you are importing data from includes a unique identifier or ID number of some sort, it is strongly recommended that you include this number as the first field in your import file. This will allow you to rerun the import routine to add additional people that prevent duplicate records from being created.

When you first execute the Import People menu option, a window appears that asks if you wish to purge people from the database that do not have a case associated with them. This will allow you to remove the extra records for people who no longer appear in your import file. Click on the Yes button to purge the unused people or the No button to continue with the import without deleting any people from the database.

After you respond to the purge question, a Windows Open File dialog window is displayed. Select a text file in the format described above to import and click on the Open button, or click on the Cancel button to cancel the import operation.


Maintain Menu Options

Options on the Maintain Menu allow you to add, edit or delete people records, as well as modify the lists of all available charges and sanctions. Additional options allow you to control the options available in all of the program fields that it here and as drop-down lists, for example, category or process method.


Maintain People

Select People from the Maintain Menu to display or modify the people recognized by the program. Any People you enter here may be associated with a case record. If an person is associated with at least one case record, they cannot be deleted. Use the Import People command on the File Menu to add a large number of people at once from another system.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.

Most of the fields on the People screen are self explanatory and their entry is optional. A last and/or first name is required. The Alternate ID field may be used to store an ID number if you track your customers in a separate database. The Group field can be used to classify different groups of people (use the Maintain Groups menu option to modify the list of available groups). The miscellaneous field is a text field that can be used to store any information that is not have a place any other available fields.


Maintain Charges

Select Charges from the Maintain Menu to display or modify the charges recognized by the program. When you first install JOT, an initial list of charges is defined for demonstration purposes. You may delete these charges or enter any additional charges that you would like to have the program recognize. If a charge is associated with at least one case record, it cannot be deleted.

Note that this window is used to modify the master list of all charges that program recognizes. To add a charge to a specific case, click on the Charges button in the upper right area of the main screen.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Maintain Sanctions

Select Sanctions from the Maintain Menu to display or modify the sanctions recognized by the program. When you first install JOT, an initial list of sanctions is defined for demonstration purposes. You may delete these sanctions or enter any additional sanctions that you would like to have the program recognize. If a sanction is associated with at least one case record, it cannot be deleted.

Note that this window is used to modify the master list of all sanctions that program recognizes. To add a sanction to a specific case, click on the Sanctions button on the main screen.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Maintain Categories

Select Categories from the Maintain Menu to display or modify the categories recognized by the program. When you first install JOT, an initial list of categories is defined for demonstration purposes. You may delete these categories or enter any additional categories that you would like to have the program recognize. If a category is associated with at least one case record, it cannot be deleted. The categories that you defined here appear in the drop-down list of the Category field on the main screen.

Many of the reports generated by the program can be set so that they will list either cases in all different categories, where they may be limited so that they will list only cases associated with a specific category. Give some thought to how you will want to report different groups of cases before determining want, if any, categories you will create.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Maintain Groups

Select Groups from the Maintain Menu to display or modify the groups recognized by the program. When you first install JOT, an initial list of groups is defined for demonstration purposes. You may delete these groups or enter any additional groups that you would like to have the program recognize. If a group is associated with at least one person record, it cannot be deleted. The categories that you define here appear in the drop-down list of the Group field on the Maintain People window.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Maintain Process Methods

Select Process Methods from the Maintain Menu to display or modify the process methods recognized by the program. The process method can be used to identify the procedure by which an individual case was processed. The process methods that you define here appear in the drop-down list of the Process Method field on the main screen. When you first install JOT, an initial list of process methods is defined for demonstration purposes. You may delete these process methods or enter any additional process methods that you would like to have the program recognize. If a process method is associated with at least one case record, it cannot be deleted.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Processing Form Layout

Select Processing Form from the Maintain Menu to control the format of the processing form that can be generated using the Processing Form for the Current Case option on the Reports Menu. The processing form is actually generated by the option on the Reports Menu. The option on the Maintain Menu should only be used to modify the format of the form. It is not necessary to make any changes to the processing form layout if you are satisfied with the format that the program uses by default. Modifying the layout should be considered an advanced option for users with some understanding of HTML. Please do not be intimidated by the apparent complexity of the format layout that is displayed for you to edit. Along with a few HTML codes, the layout contains static text and "field symbols." When the processing form is generated, these are combined and the field symbols are replaced with information that you have entered in the program for the current Case.

^name^
^casenumber^
^hearingdate^
^hearingby^
^incidentdate^
^incidenttime^
^summary^
^reportdate^
^reportby^
^entrydate^
^category^
^processmethod^
^charges^
^witness^

The final two symbols are handled a little differently, since there may be multiple charges or witness accounts associated with the case. When generating the processing form, the program will duplicate the entire line that the charges symbol (^charges^) appears on. The entire line will be repeated for each charge associated with the case. "^witness^" will be replaced with a table listing the names, dates of testimony and accounts for all witnesses entered.


Entering Your Registration Key

When you purchase Judicial Offense Tracker, you are sent a registration key code by email that will allow you to convert the program from the limited evaluation mode to the full registered version. Select Enter Registration Key from the Help Menu to display the registration window. Enter your name and registration key in the fields provided, exactly as they appear in the email message you received. We recommend that you copy and paste from the email into the registration window to save the trouble of retyping the information and to avoid the posibility of typing errors.


Reports Menu

The Judicial Offense Tracker program includes a number of reports that provide useful information about the cases you have entered. The Reports Menu is divided into three sections. The first section contains options for setting report dates and the category of cases to report. A data export option is also provided. The reports in the second section of the menu are all affected by the dates and categories that the selecting the first section. The Sanction Detail Report, for example, will only include cases between the start and dates you specify and only for the categories selected. The third section of the Reports Menu includes several reports which are not affected by purport dates or categories. The Overdue Fine Report, for example, will list all overdue fines regardless of the dates of the cases they are associated with. All reports are displayed in your default browser, from where they may be viewed, printed or saved.


Set Report Dates

When you first run the program, the report dates will default to the current month to date. Reports in the middle section of the Reports menu will only include cases with an incident date between these two dates. To change the dates that the program uses for these reports, simply select Set Report Dates from the Reports Menu. A new window will be displayed with fields for the report start and dates. Enter the dates you wish to using the fields provided or click on the calendar icons to display pop-up calendars from which you may select a date. Click on the OK button to close the window and put the dates you entered into effect or click on the Cancel button to close the window leaving report dates unchanged.


Include All Categories/Selected Categories

Reports in the middle section of the menu can also be set so that they will include only cases of a specific category. By default, the option to include all categories is selected and a check mark appears next to this menu item to indicate this. Select "Include Selected Category" from the Reports Menu to limit these reports to a single category. A new window will appear with a list of all defined categories. Select the category you wish to report from the list and click on the OK button. A check mark will now appear on the menu next to "Selected Category" and the category you have selected will be displayed on the menu.


Export Data

The Export Data option on the Reports Menu provides an easy procedure for moving data out of Judicial Offense Tracker and into other systems. The data that is selected to be exported is limited by the report dates and categories that you select at the top of the Reports Menu. When you select this option from the menu, a Windows Save File dialog is displayed. Enter a filename and click save to create the text file with your exported data. The file that is created is a tab delimited text file that can be imported into most spreadsheet or database software.


Charge Summary Report

The Charge Summary Report will provide a list of all of the charges defined in the program, along with counts of the number of cases that have this charge associated with it and a count of the number of this charges which have been marked "found responsible". The cases that are included to calculate these counts are determined by the current report dates and whether you have chosen to limit reports to a specific category. Only cases with an incident date between the start and end dates that you specify will be included in this report.


Charge Detail Report

The The Charge Detail Report will provide a more detailed view of the charges that have been entered. This report will list Case No., name, incident date, charge description and whether the person was found responsible for the charge. Only cases with an incident date between the start and end dates that you specify will be included in this report. If you have selected the option to include only a specific category of cases, then only those cases will be included in the report.


Cases with a Selected Charge Report

This report will first open a new window listing all charges defined in the program. Select a charge from the list and press enter or click OK. The program will generate a report listing case No., name, incident date, other charges and sanctions. Only cases with an incident date between the start and end dates that you specify will be included in this report. If you have selected the option to include only a specific category of cases, then only those cases will be included in the report.


Sanction Summary Report

The Sanction Summary Report will display a list of all of the sanctions defined in the program as well as a count of the number of times the sanction has been imposed and a count of the number of those imposed sanctions that are still incomplete. Only cases with an incident date between the start and end dates that you specify will be included in this report. If you have selected the option to include only a specific category of cases, then only those cases will be included in the report.


Sanction Detail Report

The Sanction Detail Report provides a more detailed view of the sanctions that have been imposed. This report will list case number, name, incident date, sanction, sanction details, fine amount, due date and date completed. The total amount for all fines listed appears at the very end of the report. Only cases with an incident date between the start and end dates that you specify will be included in this report. If you have selected the option to include only a specific category of cases, then only those cases will be included in the report.


Cases with a Selected Sanction

The Cases with a Selected Sanction report will first display a new window with a list of all the sanctions defined in the program. Select a sanction from the list and click the OK button and the program will generate a report listing all of the cases that have had that sanction imposed. This report includes case number, name, incident date, charges and other sanctions. Only cases with an incident date between the start and end dates that you specify will be included in this report. If you have selected the option to include only a specific category of cases, then only those cases will be included in the report.


Hearings Report

This report will list any cases that have had a hearing date entered. The Hearings Report will list case number, name, hearing date and heard by. Only cases with a hearing date between the start and end dates that you specify will be included in this report. If you have selected the option to include only a specific category of cases, then only those cases will be included in the report.


Appeals Report

The Appeals Report will list any cases that have had an appeal date entered. This report will list case number, name, appeal date, appeal heard by and appeal findings. Only cases with an appeal date between the start and end dates that you specify will be included in this report. If you have selected the option to include only a specific category of cases, then only those cases will be included in the report.


Past Due Sanctions Report

The past Due Sanctions Report will list any cases that have sanctions where the due date has passed in a completion date has not yet been entered. This report will include name, case number, sanction and due date. This report is not influenced by the report start and end dates or report category that you select.


Unpaid Fines Report

Any sanction that has a fine amount entered but no completion date entered is considered to be an unpaid fine. This report will list all unpaid fines, not just those that are past the due date. This report will list name, case number, sanction, fine amount and due date. A total amount for all fines listed is shown at the very end of the report. This report is not influenced by the report start and end dates or report category that you select.


All Cases for a Selected Person

This report provides a case history for a selected individual. This report first display is a new window with a list of names for all people entered in the program. Select a name from the list and click on the OK button and the program will generate a report listing all cases associated with that individual. This report lists case number, incident date, summary, charges and sanctions for the chosen person. Charges that were not marked as "found responsible" are shown in parentheses. This report is not influenced by the report start and end dates or report category that you select.


People with Two or More Cases

This report will search the database for individuals who have had two or more separate cases entered in the database. The report lists all of the cases for those people and includes name, case number, incident date, charges and sanctions. Charges that were not marked as "found responsible" are shown in parentheses. This report is not influenced by the report start and end dates or report category that you select.


Processing Form for the Current Case

Select Processing Form for the Current Case from the Reports Menu to generate a processing form for the case currently shown in the main program window. This document provides a useful summary of the case for use and hearings or meetings that take place away from the computer. The Processing Form Layout option on the Maintain Menu provides you with a way to modify the contents of the processing form is that the program generates. Modifying the HTML codes in the form layout can be challenging for some users, but CyberNiche Software can assist you in changing your form layout. The processing form is not influenced by the report start and end dates or report category that you select.