All Asset Tracker


Overview

All Asset Tracker is an easy to use database system that will allow you to manage all of your company's assets. Record as much information as you need to track using the program's 20 available data fields. Record asset descriptions, purchase dates, warranty expirations, asset values and much more. A selection of standard reports is available to easily retrieve information about assets in the database. A powerful and extremely flexible custom report tool allows you to focus on the specific information you need to access and have it presented exactly as you wish it to appear. Import and export procedures allow you to transfer information between other systems and All Asset Tracker.


Tutorial

A good way to start learning All Asset Tracker is to go through our Tutorial. This will guide you step-by-step through the process of using the program and entering information in the database


Initial Setup

Before starting to use the program actively, it is good to give some thought to the initial setup of some of the options available in the program. All of the fields that appear as drop-down lists in the program (category and manufacturer, for example) may be fully customized by the user. When the program is first installed, a list of options is available for each of these fields, but this is only our suggestion for the purposes of providing some sample data. You may modify the options we provide, or delete them all and enter your own. In this way, you may specify all of your own categories, departments, locations, etc.

Similarly, the people available to associate with assets may be easily modified at will. You may either enter people individually using the Maintain People menu option, or you may use the Import People option on the File Menu to automatically add a large number of people using a data file from a different database system.


How to Contact CyberNiche Software

You may contact CyberNiche Software by mail, by e-mail, by fax or by phone.

CyberNiche Software
35 Winchester Gardens
Carlisle, PA 17013
USA

e-mail: support@cniche.com

Phone: 717-486-8308
Fax: 267-295-6127

Our web site is at: http://www.cniche.com/


Custom Programming

While we make every effort to make our software flexible and powerful enough to meet the needs of most of our customers, we recognize that certain users will have unique requirements that are not always satisfied by the software. In response to such special requirements, we are able to customize the software according to your exact specifications. We can add additional fields, change the labels of screen fields, develop new reports or anything else you may require. Contact us at CyberNiche Software for a quote on custom changes to All Asset Tracker.


Assets

The main window of the program presents an overview of all of the information associated with an individual asset. Assets are sorted alphabetically by the asset description. You may use the navigation buttons at the bottom of the window to move between the different assets. First will move to the first asset in the database which is displayed by default when the program first opens. The Previous and Next buttons will move asset-by-asset through the database. The Last button will move immediately to the very last record in the database.

Once any number of assets have been entered, it will be much easier to locate an individual asset by using the Find button. Clicking on Find will display the search window where you may select the field that you wish to search and the specific information that you wish to search for.


Adding new assets

Click on the Add New button to add a new asset to the database. Enter information for all the fields you wish to track in the program by tabbing through the screen fields. When you have finished entering the asset's information, click on the Update button. If you change your mind about entering the asset, click on the Cancel button.

If you're entering a number of assets at once, you may click on the Add Another button instead of clicking Update. Clicking on Add Another will save the information you have just entered as an asset record and clear the window so that you may immediately began entering the next asset.


Finding an Asset

Click on the Find button to locate the information for a particular asset. After you click this button, a window will appear where you may select the field, the operator and the text or value to find. Text fields may be searched for specific text in various positions. For number, currency or date fields, you may select operators such as equals, less than, greater than, etc. True/False fields allow you to select either true or false.

If more than one record is found that matches your search, all matching records will be displayed in a list:

The asset description, the name of the person the asset is assigned to, and the department associated with the asset will be displayed for each matching record. Select the asset you wish to view and click the Select button or press Enter.


Asset Data Fields

The information for each asset is recorded in the fields listed below. Our explanation for the purpose of a field should be viewed as a suggestion only. Generally, you may enter other information of the same type in any of these fields. A date field will only accept a date value, however. Through custom programming, CyberNiche Software can alter the program to change field labels, change the type of information stored in fields or add any additional fields that you might need.

Description -- The description is the main identification of an individual asset. This is the description of the asset that appears in all of the program's standard reports. You will probably find it useful to include in most of the custom reports that you create as well. The description is a text field that may contain up to 80 characters. When you use the Next and Previous buttons to move through the individual asset records in the database, the assets are sorted alphabetically by description.

Name -- This is the name of the individual to whom the asset is assigned. Names are entered in the system using the People option on the Maintain Menu. There is also an option in the program to import a data file of names, which can be useful for loading a large number of names from a different computer system.

As with all of the drop-down list fields in the program, you may select an individual name from the list in a number of ways. Within main fields selected, you may press the first letter of a name to select the first name beginning with a letter. Press the letter repeatedly to move through all of the names beginning with that letter. You may also use the up-and-down arrow keys or click on the downward pointing arrow at the right side of the field to display the drop-down scrolling list.

Department -- Select the department associated with the current asset from this drop-down list. Departments may be entered through the Departments option on the Maintain Menu. Departments may also be associated with people (there is a department field on the Maintain People window). When you select a name and press tab to move to the next field, if there is not already a department entered, the program will automatically fill the department field with the department associated with the name you just selected.

Manufacturer -- Select the manufacturer of the current asset from the drop-down list or by pressing the first letter of the manufacturer's name. Use the Maintain-> Manufacturers window to enter or delete manufacturers.

Vendor -- For assets that were not purchased directly from the manufacturer, you may use the vendor field to identify the company that the asset was purchased through. Use the Maintain-> Vendors window to enter or delete vendors.

Model -- This is a text field to enter the model description or model number for the current asset. Of course, a model number will only be appropriate for certain types of assets (hardware rather than software, for example). Simply leave the field blank if a model number does not apply. You may enter up to 40 characters of text for the model number.

Serial Number -- Enter the serial number for assets that have a serial number associated with them. Leave the field blank for assets that do not have a serial number. You may enter up to 40 characters for the serial number.

Type -- The type field (like Category and Status) is one of those fields that you may use to group or categorize the assets in the database in the way most useful for your organization. For our examples, we have used "hardware," "software," and "furniture" as the types that our assets are associated with. You may expand on these types or delete them and enter your own values for the Types field. Use the Maintain-> Types window to modify or enter new types.

Category -- Like the Type field, the category can be used to group or classifying your assets in whatever way will be the most useful. For our examples, we have used this field to identify the party who is responsible for maintaining the asset. You may use the Maintain-> Categories window to enter your own set of category descriptions. If you do not need to group your assets by category, you may simply leave this field blank.

Status -- Use this field to record the current status of the asset. For example, whether the asset is currently in use, in storage or out for repair. Use the Maintain-> Status to enter whatever status descriptions will be most useful to you.

Location -- The location of the asset. Use the Location option on the Maintain Menu to enter a set of meaningful locations for your organization. These might be the cities of different corporate sites, names of different buildings or different floors within a single building.

Sub-Location -- this field can be used to enter a more detailed and specific location for the current asset than the general location chosen for the Location field. This is a free text field where you can enter up to 40 characters of information. Leave the field blank if you do not need to record a more specific location for the asset.

RAM, CD/DVD, HD -- these three fields, located at the top of the right hand side of the main screen, are provided to record some of the details about computers that are entered as assets. You may use these fields to enter the amount of memory, the types and numbers of CD and DVD drives, and the hard drive capacity of the PC. For any assets that do not happen to be personal computers, you will probably want to just leave these fields blank. The PC Details report on the Reports Menu provides a list of any of the assets that has had information entered in any of these three fields.

Price/Value -- These fields provide a place to store the original price paid and the estimated current value of assets. These are numeric fields that are formatted for currency. Leave these fields blank if you do not need to track this information.

Purchase Date -- Enter the date that the asset was first purchased. You may either enter the date at the keyboard or click on the calendar icon to the right of the date field to display a pop-up calendar.

Warranty Date -- enter the date that the warranty for the current asset is due to expire. You may either enter the date and the keyboard or click on the calendar icon to the right of the date field to display a pop-up calendar. The Warranty Expirations report provides a list of the assets whose warranties are due to expire during any period of time that you select.

Notes -- this is an unlimited, scrolling text field where you may record any other information related to the current asset. You may use this to record the repair history of the asset, or record any other information does not seem to fit in any of the other data fields provided.


File Menu Commands

Commands located on the File Menu allow you to import people into the system using a data file from a different system or exit from the program.

Importing People

The Import People option on the File Menu accepts a tab delimited text file. The file should have one person record per line with a tab separating each field. The fields in the data file must be in the following order:

  1. Alternate ID
  2. First Name
  3. Last Name
  4. E-mail
  5. Phone
  6. Fax
  7. Address Line 1
  8. Address Line 2
  9. Address Line 3
  10. Department
  11. Miscellaneous

Note: an import routine that supports a different data format can be provided to you through custom programming. Contact CyberNiche Software for details.

If the other system you are importing data from includes a unique identifier or ID number of some sort, it is strongly recommended that you include this number as the first field in your import file. This will allow you to rerun the import routine to add additional people that prevent duplicate records from being created.

When you first execute the Import People menu option, a window appears that asks if you wish to purge people from the database that do not have an asset associated with them. This will allow you to remove the extra records for people who no longer appear in your import file. Click on the Yes button to purge the unused people or the No button to continue with the import without deleting any people from the database.

After you respond to the purge question, a Windows Open File dialog window is displayed. Select a text file in the format described above to import and click on the Open button, or click on the Cancel button to cancel the import operation.


Importing Assets

The Import Assets option on the File Menu accepts a tab delimited text file. The file should have one asset record per line with a tab separating each field. The fields in the data file must be in the following order:

  1. Asset Description
  2. First Name
  3. Last Name
  4. Department
  5. Manufacturer
  6. Vendor
  7. Model
  8. Serial Number
  9. Type
  10. Category
  11. Status
  12. Location
  13. Sub-Location
  14. RAM
  15. CD/DVD
  16. HD
  17. Purchase Price
  18. Current Value
  19. Purchase Date
  20. Warranty Expiration Date
  21. Notes

Any fields that are not available for import may be excluded. The position of available fields is determined by the number and placement of tab characters in the file. Note: an import routine that supports a different data format can be provided to you through custom programming. Contact CyberNiche Software for details.

After you respond to the warning and indicate that you wish to continue, a Windows Open File dialog window is displayed. Select a text file in the format described above to import and click on the Open button, or click on the Cancel button to cancel the import operation.


Export Assets

The Export Data option on the Reports Menu provides an easy procedure for moving data out of All Asset Tracker and into other systems, such as a spreadsheet or database program. When you select this option from the menu, a Windows Save File dialog is displayed. Enter a filename and click save to create the text file with your exported data. The file that is created is a tab delimited text file that can be imported into most spreadsheet or database software.


Maintain Menu Options

Options on the Maintain Menu allow you to add, edit or delete records for the people that assets may be linked to, as well as modify the lists of all the other drop down lists on the main screen, such as department, location and status.


Maintain People

Select People from the Maintain Menu to display or modify the people recognized by the program. Any People you enter here may be associated with an asset record. If a person is associated with at least one asset record, they cannot be deleted. Use the Import People command on the File Menu to add a large number of people at once from another system.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons (First, Previous, Next and Last) may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.

Most of the fields on the People screen are self explanatory and their entry is optional. A last and/or first name is required. The Alternate ID field may be used to store an ID number if you track your employees in a separate database. The Department field can be used to classify different groups of people (use the Maintain Departments menu option to modify the list of available departments). The miscellaneous field is a text field that can be used to store any information that is not have a place any other available fields.


Maintain Categories

Select Categories from the Maintain Menu to display or modify the categories recognized by the program. When you first install All Asset Tracker, an initial list of categories is defined for demonstration purposes. You may delete these categories or enter any additional categories that you would like to have the program recognize. If a category is associated with at least one asset record, it cannot be deleted. The categories that you define here appear in the drop-down list of the Category field on the main screen.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Maintain Departments

Select Departments from the Maintain Menu to display or modify the departments recognized by the program. When you first install All Asset Tracker, an initial list of departments is defined for demonstration purposes. You may delete these departments or enter any additional departments that you would like to have the program recognize. If a department is associated with at least one asset record, it cannot be deleted.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Maintain Locations

Select Locations from the Maintain Menu to display or modify the locations recognized by the program. When you first install All Asset Tracker, an initial list of locations is defined for demonstration purposes. You may delete these locations or enter any additional locations that you would like to have the program recognize. If a location is associated with at least one asset record, it cannot be deleted. The locations that you defined here appear in the drop-down list of the Location field on the main screen.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Maintain Manufacturers

Select Manufacturers from the Maintain Menu to display or modify the manufacturers recognized by the program. When you first install All Asset Tracker, an initial list of manufacturers is defined for demonstration purposes. You may delete these manufacturers or enter any additional manufacturers that you would like to have the program recognize. If a manufacturer is associated with at least one person record, it cannot be deleted.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Maintain Status

Select Status from the Maintain Menu to display or modify the status descriptions recognized by the program. The status descriptions that you define here appear in the drop-down list of the Status field on the main screen. If a status is associated with at least one asset record, it cannot be deleted.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Maintain Types

Select Types from the Maintain Menu to display or modify the types recognized by the program. The type field can be used to group or classify assets in any way you choose. The types that you define here appear in the drop-down list of the Types field on the main screen. When you first install All Asset Tracker, an initial list of types is defined for demonstration purposes. You may delete these types or enter any additional types that you would like to have the program recognize. If a type is associated with at least one asset record, it cannot be deleted.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Maintain Vendors

Select Vendors from the Maintain Menu to display or modify the vendors recognized by the program. The vendor identifies the company that the asset was purchased through, if this was different than the manufacturer. The vendors that you define here appear in the drop-down list of the Vendor field on the main screen. When you first install All Asset Tracker, an initial list of vendors is defined for demonstration purposes. You may delete these vendors or enter any additional vendors that you would like to have the program recognize. If a vendor is associated with at least one asset record, it cannot be deleted.

The buttons at the bottom of this window behave the same way as in other parts of the program. The navigation buttons may be used to move between different records, Find will find a specific record, Add New will add a new record and Delete will delete a record. Click on Ok to close the window when you are finished.


Entering Your Registration Key

When you purchase All Asset Tracker, you are sent a registration key code by email that will allow you to convert the program from the limited evaluation mode to the full registered version. Select Enter Registration Key from the Help Menu to display the registration window. Enter your name and registration key in the fields provided, exactly as they appear in the email message you received. We recommend that you copy and paste from the email into the registration window to save the trouble of retyping the information and to avoid the posibility of typing errors.


Reports Menu

The All Asset Tracker program includes a number of reports that provide useful information about the assets you have entered. A number of these reports have additional options that you may specify to control what information is included in the report. These options are discussed in the sections below for the individual reports. Note that almost all of the standard reports included with the program can be duplicated as custom reports. With custom reports you have additional options for including additional columns, sorting in different ways and selecting different records to include in the report. All reports are displayed in your default browser, from where they may be viewed, printed or saved.


Include All Categories/Selected Categories, Departments, Etc.

The standard reports listed in the first section of the reports menu are all tied to one of the drop-down list fields that appears on the main screen, such as category, name or department. These reports will either list all assets that are sorted by the specific field, or they may be limited to assets with a single value for that field. The report of Assets by Category, for example, will either list all assets sorted by category or you may select a specific category and only assets assigned to that category will appear in the report.

Once you have entered some assets, it is best to spend a little time experimenting with the different options for these reports to get a feel for how they work. Remember that you do not need to print the reports unless you choose to, so it is easy to experiment without wasting paper.


All Assets by Description

The All Assets by a Description Report provides a complete list of all assets entered in the database. It is sorted by the asset description, which is included as the first column. This report also includes the name of the person assigned to the asset, category, type and location.


Value Report

The Asset Value Report focuses on the financial value of assets. The price paid and current value fields are both included in are totaled at the end of the report. All assets are included and are sorted by asset description. There are also columns for name, manufacturer and vendor.


Warranty Expirations

The Warranty Expiration Report prompts you for a start date and an end date in a new window. Any assets that have a warranty expiration date between the two dates that you specify will be listed on the report. The report shows as a description, name, manufacturer, vendor, purchase date and warranty expiration date. It is sorted by asset description.


Serial Number Report

The Serial Number Report provides an easy list for all assets that have had a serial number entered. The report includes asset description, name, manufacturer, model and serial number. It is sorted by asset description. Any assets that have not had a serial number entered will not be included in this report.

Note that if you are looking for an asset with a specific serial number, it is better to use the Find button on the main window and search for that serial number. Additional report options are available through creating a custom report. This would allow you to sort the report in different ways or included only specific categories or types of assets.


PC Details Report

This report includes only assets that have had some information entered in one of the three fields that are reserved for PC related information: RAM, CD/DVD and HD. The report includes an asset description, name, manufacturer, model, RAM, CD/DVD and HD. It is sorted by the asset description.


Purchases Report

Like the Warranty Expiration Report, the Purchases Report will first prompt you to enter a start date and an end date in a new window. After you select the dates to use, the program will generate of report including only assets with a purchase date between the two dates you specified. The Purchases Report includes columns for asset description, name, manufacturer, vendor, purchase date and purchase price. A grand total for all of the purchase prices listed appears at the end of the report.


Custom Reports

As well as the standard reports described previously, All Asset Tracker will allow you to create totally customized reports that include only the information you want in the order you want it presented. Select the Custom Reports option on the Reports Menu. These reports can be displayed on screen, printed or saved to files.

When Custom Reports is selected, a list of all available fields is displayed in the left top corner of a new window. These are the fields of data that the program allows you to enter for each asset and that may become columns in your report.

Select the fields that you wish to show in your report and click on the arrow button pointing to the right to move them into the "Fields to Report" list. If you add a field by mistake, click on the arrow button pointing left to remove it. If you wish to change the order of the fields in your report, click on the up or down arrow buttons to move a highlighted field name up or down.

When each field is selected in the "Fields to Report" list, options affecting that specific field are displayed in the far right side of the window. Check off the "Hide Field" option if you wish to use a field for selecting which records to report but do not actually want a column in your report for that field. You may also enter Selection Criteria for each field you have selected to include in your report. This allows you to decide which assets should show up as rows in your report. The specific criteria you may enter will depend on the type of data that the field stores.

Three drop down lists at the bottom left of the Custom Reports window allow you to control the order in which the selected records appear in your report. The three drop-down lists are labeled primary, secondary and tertiary sort. Each list contains all of the available database fields. You might select purchase date for the primary sort and asset description for the secondary sort, for example. This would sort the rows of your report by purchase date first, and then sort by description within each date.

Once you have entered all of the details to design your custom report, you may save the report specification in order to quickly run the same report at a later date. Use the options on the File Menu on the Custom Report window to save reports, to open previously saved reports or to clear all report options in order to start a new report.